Undisplayed picture in link to translated article

5 months 11 hours ago - 5 months 11 hours ago #70792 by hervemlam
Hello forum,

In my website I create articles about music albums in French, then use the multilanguage functionality to create a translated article (towards English).
Since the sleeve of an album is currently the same in both languages ;) I set the field so that I insert it only once, and the translated article should contain a pointer to the original article. It works fine.

Except when I create a link to a translated article. Example:


You can see it here: http://japprecie.raidghost.com/en/dralms-shook

What can I do to prevent it?

Regards,
HervE

MySQL 5.5.5
PHP 7.0.26
Joomla! 3.8.6
FLEXIcontent 3.2.1.12
Attachments:

Please Log in or Create an account to join the conversation.

5 months 9 hours ago #70800 by ggppdk
Hello

so the image field is in "untranslated" mode ?

possibly there is a bug here


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

5 months 7 hours ago #70810 by micker
yes and that return <img src="/"

FLEXIcontent is Free but involves a very big effort on our part.
Like the our support? (for a bug-free FC, despite being huge extension) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing reviews. Thanks![/size]

Please Log in or Create an account to join the conversation.

5 months 6 hours ago #70812 by hervemlam
Yes, I don't know why.

My image field is defined this way:



And my relation field is coded this way:


What's your opinion?
Is there a way to solve it, or is it a bug?
HervE

MySQL 5.5.5
PHP 7.0.26
Joomla! 3.8.6
FLEXIcontent 3.2.1.12
Attachments:

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago #70834 by ggppdk
Hello

i think it is a bug,
- probably the untranslated value is retrieved for the field
but the folder is not correctly calculated

and i think i know why
it is
because method ... getOriginalContentItemids()
is not called when creating the related items list


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago - 4 months 3 weeks ago #70859 by hervemlam

ggppdk wrote: i think it is a bug,
- probably the untranslated value is retrieved for the field
but the folder is not correctly calculated

Hello,
That's it.
For when I manually copy the folder structure from /images/stories/flexicontent/item_XXX_field_NN into a new folder item_XXY_field_NN, where XXX is the original item ID and XXY the translated item ID, it works.
(I did it before for previous articles. I thought my data was corrupted somehow. But now I know it isn't.)

and i think i know why
it is
because method ... getOriginalContentItemids()
is not called when creating the related items list

OK. When do you think it will be corrected?

Good night.
HervE

MySQL 5.5.5
PHP 7.0.26
Joomla! 3.8.6
FLEXIcontent 3.2.1.12

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago - 4 months 3 weeks ago #70966 by ggppdk
Hello

i have made a fix please test in a copy of your website
(use install via URL)

https://github.com/FLEXIcontent/flexicontent-cck/archive/3.2.1.x-stable.zip


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!
The following user(s) said Thank You: hervemlam

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago #70969 by hervemlam
Hello,

I have no copy of my website, but I trust you ;-)
(I made a backup before installing the zip file, just in case.)

It works fine! Many thanks!

Good night.
HervE

MySQL 5.5.5
PHP 7.0.26
Joomla! 3.8.6
FLEXIcontent 3.2.1.12

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.