Manual display of field in custom layout not shown

1 year 1 month ago - 1 year 1 day ago #69436 by drangelis
Hi,
I updated the Flexicontent system to a new version (3.2.1.2) and stopped working $item->fields->{"display_medium_src"}.
I need to call a medium sized image in the ITEM LAYOUT (modular.php). For example:
			<div class="team-img">
				[b]<img src="[/b]<?php echo $this->fields['portretas1']->display_medium_src; ?>[b]">[/b]
			</div>
Please help me.

P.S. Joomla version 3.7.5

Please Log in or Create an account to join the conversation.

1 year 1 month ago - 1 year 1 day ago #69438 by ggppdk
Hello

Has the image / gallery field been added in the "Renderonly" position ?
so that it gets created


Also other thing to look for
-- Is the image / gallery field flagged to be used in a usergroup ?
if so then
$this->fields['portretas1']->display_medium_src
will be an array

-- have you changed the field alias ?


Finally our default setting for parameter (Advanced TAB in component configuration)
"Always create field HTML"
is "Never unless in a field position"

it is best to use the above and add field in render-only position of your layout


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

1 year 2 days ago - 1 year 1 day ago #70241 by drangelis
Thanks for help. Problem was with field configurations. The script did not work because the field had a "Use field in a group" setting.

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.