Language Associations is wrong filtered in front edition

9 months 2 weeks ago - 9 months 2 weeks ago #72011 by charlynancy
Hi,
With 3.2.1.12 release.
When you edit an item in frontpage.
The Language Associations is bad filtered.
Example : french item edited in front , when you click on select to associate an english item, you obtain a page with only french item
If you do that in backend it's ok : french item --> Language Association --> Select --> give English items

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago #72030 by ggppdk
Hello

we should look into this and fix it (should not be difficult)

I think there is a relevant change in Joomla 3.8.4

please post reminder after monday if you do not get a reply sooner

Regards


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago #72038 by charlynancy
Hello Georgios,
I created an issue on Git. Here it is

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago #72067 by ggppdk
Hello

something is overwritting the URL language variable
i have made a fix for it locally


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago #72078 by ggppdk
Hello

Fixed it
also some UX improvements

in popup items listing for selecting an item to associate

- show if an item is already used in other association group and prevent its selection
- show if an item is already used in current association group

You can use install via URL in Joomla extensions manager in a testing website to test the fix
https://github.com/FLEXIcontent/flexicontent-cck/archive/3.2.1.x-stable.zip


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

9 months 1 week ago #72092 by charlynancy
Hello Georgios,
Thank you for your work
i am installing a new test site to implement your fix
(the site concern a project in which me must now integrate collaborative functions,
i am also testing ACL features with the fields)
I will test it and i will report you the results this afternoon.

Please Log in or Create an account to join the conversation.

9 months 1 week ago #72093 by charlynancy
(Sorry for the delay to report : my test site had a bad configurations with the URL rewriting and the caching system)
I tested your fix and it works perfectly.
UX improvements are verry usefull to avoid some mistake.

So as usual it is perfect and more than perfect with your improvments.
Thank you verry much Georgios.

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.