How does Import works

3 years 4 months ago #51318 by j0rged
Hello, can you help me with a Inport feature?
I had read a forum but not find what I need.
I try to import an item: reated a csv-file, where
in 1 line listed some fields,so

created_by~~title~~metadesc~~metakey~~maintext
From next line#2 - Here comes USERID 111~~Here comes TITLE~~here comes META DESCRIPTION~~Meta Key1, Meta key2~~Here comes Main text

and with
some new line too doesnt works/n~~

Would you tell me please, what is wrong here, because it doesnt works

In configuration I have all default settings,exept some setted fileds: in "Item type" -> I choose type of item
in "Creator (Author") -> checked "created_by" , because I have this column in my file
in "Meta Data" -> I choose both "use metadesc and metakey"
in "Primary category" -> I choose some category
in "Debug first # items" -> I set it to "1" instead "2" , because I have only 1 item
in "Items per import step" -> I set it to "1" too

my Field Separator * -> ~~ (default)
in Field Encloser Character -> nothing (default)
Item Separator * -> \n~~

If I click on "Prepare Import Task" or "Test file format", I see blank page

If I check in configuration "Enable this if you have redudant columns." and click on "Prepare Import" I see errors, no one field was readed, so:
Column 'maintext 111' : field name NOT FOUND, column will be ignored ... and so on which all next text

where 111, the UserID which beginn the next line#2

Can you tell me what is wrong here or what do I forgotten to set?

Thank you

Please Log in or Create an account to join the conversation.

3 years 4 months ago #51319 by ggppdk
Hello,

see the example file

title ~~ text ~~ textfield3 ~~ emailfield6
~~ title 4 ~~ description 4 ~~ textfield3 value ~~ userd@somedomain.com
~~ title 5 ~~ description 5 ~~ textfield3 value ~~ usere@somedomain.com


1. the maintext has field name:
text
aka header of column should be: text

2. and the ITEM(record) separator is \n~~
so after every new line you need:
~~

-- see the example above and the example given inside the import form, (scroll down)



please do above too and re-test



if you do not like \n~~, or if you have some other CSV format, then just enter a proper CSV format for your case


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

3 years 4 months ago - 3 years 4 months ago #51389 by j0rged
Thank You , so works!
But it is some problem with translation of metadesc :
the fields in my csv are:
state~~metadesc~~metakey~~title~~text

If I check in settings :
Creator (Author) -> a. Current User
I will see (after click on "Prepare") that my 2.column, META desc is named "Creator - Author" - see Screenshot - 10_12

if I check in settings:
Creator (Author) -> b. Use 'created_by' column containing USER IDs, e.g. 457
then create this column in CSV (with value e.g. 111) so I will see all the same: the next column will be named "Creator-Author" althrough it should be Meta Description


I think that it is just wrong translation or not?


2. after 1.item I set the "Item Separator" on the end, so: \n~~
but after importing I see the \n in the text of description, see Screenshot - 10_12 002. In frontend the same
Can I fix it ?


Thank you
Attachments:

Please Log in or Create an account to join the conversation.

3 years 4 months ago #51390 by ggppdk
Hello

it should import properly, just the the column title is wrong,


Fixed here:
https://github.com/FLEXIcontent/flexico ... b58b49bacc

thanks for clear report on this issue


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

3 years 4 months ago #51441 by j0rged
thank you for fixed.

Can you tell me yet how can I fix the problem with "\n"-Char in Text of Description?
Is it just by me something wrong or not?

So I set just on end of Text of description (last column by me) the "Item Separator" (by default it is "\n~~") but after import I see in text of description this char, so "\n"
My csv looks like:
state~~metadesc~~metakey~~title~~text
~~0~~test Meta~~META Keyword-1, Meta Keyword-2~~Title of Item~~Main Text, Description \n~~
~~0~~test 2 Meta~~META Keyword-3, Meta Keyword-4~~Title of Item2~~Main Text 2, Description 2

Please Log in or Create an account to join the conversation.

3 years 4 months ago #51442 by ggppdk
Hello

\n

is an "escaped sequence" of a non-printable character

\n

is the new line

-- so wherever it is expected \n
you CSV file should have a new line


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

3 years 4 months ago #51492 by j0rged
this is the Problem - because I see it in Text of Description on frontend too.

I can to add manually in Description (in Editor) the \n (new line)- too and will see then: \n on fontend (Screenshot - 12_12 004)

For Import-Process I tried now to change the position of colums (Screenshot - 12_12 002) and set on last place the column "State", but it does not work, so the "State" is then "Unknown" (Screenshot - 12_12).
This is not so big problem as with description, I can set the State after Import manually, but I think that something is wrong

Thank you
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.