[EXPLAINED, instead use category / menu settings] Filter module: 'Initial Filter' values is ignored

6 months 1 week ago - 6 months 1 week ago #70006 by Mick
Hello,

I'm using FC 3.2.1.5. The question I have concerns FlexiFilter.

There is a section named "Initial Filter values". In this section, I type "8##2", to have an automatic filter on one specific Type (knowledge base).

On the left part, the filter is correctly applied, I can see my type "knowledge base" checked.
The issue is that on the right part, where I can find my articles, the filter does not work, there is no filter on "knowledge base"!

As you can see on my file attached, the filter is on "knowledge base", but on the right part, I can find "defect" article.

Do you know why ?

Thank you!
Michaël
Attachments:

Please Log in or Create an account to join the conversation.

6 months 1 week ago - 6 months 1 week ago #70036 by ggppdk
Hello

Do you know why ?


yes, there is no bug

you have added the initial filter values to the module configuration !
- so the form in the filtering module needs to submit , then it will have an effect

if you want to the imitation to be applied in the both the category view (on its first display) and in the document type filter shown in the filtering module
- then remove the "initial filter values" from module configuration
and find same parameter "initial filter values, inside category configuration and add it there

NOTE: you can add the limitation at some parent category and let this category and its sub-categories be effected
or you can even add this limitation to the component configuration and thus all categories will be effected by default


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!
The following user(s) said Thank You: Mick

Please Log in or Create an account to join the conversation.

6 months 1 week ago - 6 months 1 week ago #70082 by Mick
Hi!

I just tried this and it works correctly :)

Thank you!

Michaël

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.