Feed view appear as HTML view, and a warning message is shown

More
9 months 3 weeks ago - 9 months 2 weeks ago #69655 by Chabi01
Hi,
I try to generate a rss page for 2 categories but i have the issue : WARNING: Document format should be: feed but current document is: html

I try to find what is generating this issue but i don't find it... Any clue to help me ? How to find the plugin causing this ? Even if i find it and deactivate it, how can i keep my plugin working on other pages ?
Thanks for your help and ideas :)

Xavier
EDIT : if i search on Google, i found page from this site with the exact same issue : mail.flexicontent.org/site-content/73-co...ration.feed?type=rss
...


By the way, by searching on the web i found this page in Google results : www.flexicontent.org/documentation/tutorials.feed?type=rss
Check it...
Last edit: 9 months 2 weeks ago by ggppdk.

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago - 9 months 2 weeks ago #69656 by ggppdk
Hello

it is what the message says,
your website has a system plugin that is forcing current document
The issue is happening before FLEXIcontent component code is reached !

only way to workaround this issue is to add to our RSS links &format=feed
so
http://www.flexicontent.org/site-content/73-configuration.feed?type=rss

will become
http://www.flexicontent.org/site-content/73-configuration.feed?type=rss&format=feed


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!
Last edit: 9 months 2 weeks ago by ggppdk.

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago - 9 months 2 weeks ago #69657 by Chabi01
As usual Georges : thank you :)

before asking here, i search on the web (saw here in the forum and on github) but didn't found a working solution.
The example you gave me solve the issue : by adding at the end "&format=feed" solve the issue.
The only thing is : why FC doesn't put this directly when i click on "rss" button ?

Thanks again Georges :)
Xavier
Last edit: 9 months 2 weeks ago by ggppdk.

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago - 9 months 2 weeks ago #69659 by ggppdk
Hello

this is Joomla core issue,
if a system plugin calls
JHtml::...()

then the document is forced to be of type "HTML"

i think since this is an RSS url,
-- it is ok to add enable this workaround always
we can not have users repeately reporting

Will add it in next release, i will provide patch instructions here in the evening


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!
Last edit: 9 months 2 weeks ago by ggppdk.

Please Log in or Create an account to join the conversation.

More
9 months 2 weeks ago - 9 months 2 weeks ago #69760 by ggppdk
Hello

(fix for next release)

we have forced
&format=feed
to always appear in SEF urls for feed view,

this will overcome the bug


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!
Last edit: 9 months 2 weeks ago by ggppdk.

Please Log in or Create an account to join the conversation.

More
9 months 2 weeks ago #69765 by Chabi01
Hi Georges,
Again and always, thank you for your work :)
Have a nice day :)
Xavier

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.