[ZipArchive needed to be installed on server] Fatal error in php 7.0.20

9 months 2 weeks ago - 9 months 2 weeks ago #68199 by seabird
Hello,

I use flexicontent 3.1.1 and I test on php 7.0.20.
I have no problem in php 5.6 but in php 7.0.20 I have a fatal error in frontend:
Fatal error: Class 'ZipArchive' not found in .../components/com_flexicontent/classes/flexicontent.helper.php on line 7497

Strange,

Eric

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago #68200 by ggppdk
Hello

in v3.1.1 you need to add loading of ZipArchive
in v3.2.0 this need is removed

Please ask your webhost to enable usage of ZipArchive


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago - 9 months 2 weeks ago #68207 by seabird
Hello,

I forgot to install the librairie php7.0-zip on the server. it's Ok now on php 7

But It's strange I did not install php5-zip for php5 and there is no problem with ZipArchive on php 5.6

Ziparchive only used on php 7 ???

Eric

Please Log in or Create an account to join the conversation.

9 months 2 weeks ago #68210 by ggppdk
Hello

Ziparchive only used on php 7 ???


ziparchive is commonly load in servers but it is optional in both PHP 5.6 and PHP 7


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.