{loadposition } Existe t'il un équi. dans Flexi ? [résolu]

More
6 years 4 months ago - 6 years 4 months ago #22623 by netcoupe
Bonjour,

En effet je m’aperçois que dans les articles
affichés par Flexi l'intégration du contenu
d'un module ne fonctionne pas avec cette syntaxe.

A+

Si deux solutions se présentent, prend la mauvaise au cas où tu te trompes.
Last edit: 6 years 4 months ago by netcoupe.

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #22624 by yopyop001
Bonjour,

Normalement cela fonctionne, il faut éditer le champs dans lequel tu veux l'afficher (par exemple le champs description') et cocher 'Activer les plugins de contenu' et sélectionner loadmodule dans la liste.

Il existe également un champs flexicontent : LoadModule qui permet de charger un module dans une position de template Fllexicontent.

A plus tard

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #22625 by netcoupe
La syntaxe c'est avec { } ?
On appelle le module par l'id ou son nom ?

A+

Si deux solutions se présentent, prend la mauvaise au cas où tu te trompes.

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #22626 by yopyop001
Re,

Si tu veux charger un module dans un champs textarea par exemple, édite le champ en question (Flexicontent > Champs > Modifier le champs > et active le paramètre dont je parle dans le précédent post).

Et dans ce cas, tu utilises la même syntaxe que dans les articles standards de Joomla {..}

Si tu utilise le champs de type LoadModule, il te demandera dans les paramètres du champs le module que tu souhaites afficher (par position ou nom.) Il faudra alors ne pas oublier de glisser ce champs dans une position du template.

A plus

Please Log in or Create an account to join the conversation.

More
6 years 4 months ago #22627 by netcoupe
Je te remercie pour la réponse.
En fait je ne trouvais pas paramètre en question.
C'est effectivement dans champs que je l'ai trouvé...
et bien sur cela fonctionne.

Il me reste un point a traiter avec Flexi:
Quelle technique employer, pour afficher à partir
d'un item de menu une série d'articles sous formes
de blog en sélectionnant plusieurs catégories comme
critère de sélection de ces articles...

Si deux solutions se présentent, prend la mauvaise au cas où tu te trompes.

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #27514 by ggppdk
Please besides:
-- selecting the content plugin loadposition, make sure

1. you set "Trigger Content Plugins" to Yes (take care that there is one more such parameter for Description Field)

2. also make sure that you have a space after loadposition
e.g:
{loadposition left}

3. Also if your field is description or textarea , click to disable the WYSIWYG editor and check if there is some HTML in the above text such as   etc

4. Also test with another module position, and make sure that the modules in the desired position produce some output


-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #27516 by micker
sinon utilise module anywhere qui te permet plus de varaiante
a plus

FLEXIcontent is Free but involves a very big effort on our part.
Like the our support? (for a bug-free FC, despite being huge extension) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing reviews. Thanks![/size]

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #28573 by tonnick
hello !

j'essaie de charger un module dans un article, mais pas moyen avec le load position :
flexicontent : version 2.0 RC8 (r1465)
joomla 2.5
plugin ok
configuration : Exécuter les plugins de contenu oui
module position : 100 (pourquoi pas ? :) )
editeur : descativé (pour eviter l'ajout de balise p)

et pourtant j'ai juste {loadposition 100} qui s'affiche dans mon article :/

Est ce que flexicontent ne comprendrait pas ces balises ou il me manque qq chose ?

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #28575 by ggppdk

ggppdk wrote: Please besides selecting the content plugin loadposition, make sure

1. you set "Trigger Content Plugins" to Yes (take care that there is one more such parameter for Description Field)

2. also make sure that you have a space after loadposition
e.g:
{loadposition left}

3 Also if your field is description or textarea , click to disable the WYSIWYG editor and check if there is some HTML in the above text such as   etc

4. Also test with another module position, and make sure that the modules in the desired position produce some output



-- FLEXIcontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #28584 by tonnick
ok didn't see the one on description field ! ;) it works !

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.