Plugin for Advanced Links of JCE 2.0 (Joomla 1.7, FC 2.0)

7 years 7 months ago - 7 years 6 months ago #19653 by Anonymous
Here's a plugin for JCE 2.0. It creates links to items, categories and tags of flexicontent 2.0.
It ported by me from plugin for FC 1.5.
Please note, it is for Joomla 1.6, 1.7 and it`s not working in Joomla 1.5.
I hope it will be useful. Use it if you wish.

This version adapted for JCE 2.0.15 for Joomla 1.7
Attachments:

Please Log in or Create an account to join the conversation.

7 years 7 months ago #19655 by ggppdk
Thanks for contribution.

The original for JCE 1.5.x for J1.5 was written by Emmanuel, and then Rehne altered it to be compatible with JCE 2.0 for Joomla 1.5

I am thinking if these should come with the main installation package.

I don't know why Emmanuel did not include them in the main package, i will ask him when i have the chance.

Regards


-- Flexicontent is Free but involves a big effort on our part.
Like the our support? (for a bug-free FC, despite having a long list of functions) Like the features? Like the ongoing development and future commitment to FLEXIcontent?
-- Add your voice to the FLEXIcontent JED listing with a 5-star review. Thanks!

Please Log in or Create an account to join the conversation.

7 years 7 months ago #19666 by Anonymous
Sorry, the first post, I attached a file with incorrect copyright data. Here is the correct package, where Emanuel and Ryan are listed as co-authors
Attachments:

Please Log in or Create an account to join the conversation.

7 years 7 months ago #19811 by pshoeg
Hi there, I can't install any of the packages. I'm using Joomla 1.7.2, JCE 2.0.15 and the newest beta of FlexiContent 2.

I get Incorrect Add-on version. This add-on may be for an earlier version of JCE. Please install an updated version of this add-on.

Please Log in or Create an account to join the conversation.

7 years 7 months ago #19839 by Rehne

pshoeg wrote: Hi there, I can't install any of the packages. I'm using Joomla 1.7.2, JCE 2.0.15 and the newest beta of FlexiContent 2.

I get Incorrect Add-on version. This add-on may be for an earlier version of JCE. Please install an updated version of this add-on.


Hi,

aazam must make some adjustments in his plugin
how I did it for the plugin for joomla 1.5 and FC 1.5
http://www.flexicontent.org/forum/index.php?f=27&t=3630&hilit=jce&rb_v=viewtopic&start=10
because the JCE Installer (JCE 2.0.15) looks for a version 2.1
i do not know why but i've adapted it
and then it works

Regards

Please Log in or Create an account to join the conversation.

7 years 6 months ago #19867 by pshoeg
Hi there,

When I'm linking from one article to another I use the JCE Editor and choose the article from the 'content' tree. However, when I do that, the SEF for some reason doesn't work, and doesn't show the menu either.

For instance, when I'm at a page, say http://domain.com/web/flex/driving/ and click on a link to the article that's at http://domain.dk/intranet/building/alarm/ it instead goes to http://domain.com/component/content/art ... /483-alarm

Am I doing anything wrong? Is every article supposed to have a menu item?

Please Log in or Create an account to join the conversation.

7 years 6 months ago #19868 by pshoeg
Rehne,

It's already set to 2.1, so I can't figure out what the issue is.

Please Log in or Create an account to join the conversation.

7 years 6 months ago #19873 by Rehne

It's already set to 2.1, so I can't figure out what the issue is.


hi,
you can install the plugin or not?

my note on JCE Installer (JCE 2.0.15) looks for a version 2.1
only affects the installation

I get Incorrect Add-on version. This add-on may be for an earlier version of JCE. Please install an updated version of this add-on.


and not your described Linking/SEF problem
i'm going to watch it, if time permits
but i am currently using only Joomla 1.5 and FC 1.5.6
and not like you Joomla 1.7 and FC 2.0

Regards

Please Log in or Create an account to join the conversation.

7 years 6 months ago #19874 by pshoeg
I can't install, it says it's for the wrong version of JCE. But in the installer, it's already corrected to version 2.1, so don't know where else to edit it to be allowed to install.

Please Log in or Create an account to join the conversation.

7 years 6 months ago #19879 by Rehne

pshoeg wrote: I can't install, it says it's for the wrong version of JCE. But in the installer, it's already corrected to version 2.1, so don't know where else to edit it to be allowed to install.


try this file
and give feedback
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: vistamediajoomlacornerggppdk
© 2018 Flexicontent. All Rights Reserved.